summaryrefslogtreecommitdiff
path: root/script/meson.build
diff options
context:
space:
mode:
authorJannis Hoffmann <jannis@fehcom.de>2024-07-14 22:30:34 +0200
committerJannis Hoffmann <jannis@fehcom.de>2024-07-14 22:30:34 +0200
commit5e84d7b76ce1cccdaf0900d62a94d0d1d88cdd62 (patch)
tree61500c277101ec46af8fed732dfe1c17b941b42c /script/meson.build
parent1087d4df2a7342d2832ba3bab1843bf4a3040775 (diff)
convert to the meson build system
This removes a lot of files. Remove all conf-* files. The settings move to meson.options. Add editor config. Remove the auto_*.h files. They move to config.h.in.
Diffstat (limited to 'script/meson.build')
-rw-r--r--script/meson.build15
1 files changed, 15 insertions, 0 deletions
diff --git a/script/meson.build b/script/meson.build
new file mode 100644
index 0000000..e4d647b
--- /dev/null
+++ b/script/meson.build
@@ -0,0 +1,15 @@
+scripts = ['https@.sh', 'sslcat.sh', 'sslconnect.sh']
+
+renamed = []
+
+foreach s : scripts
+ renamed += s.substring(0, -3)
+endforeach
+
+install_data(
+ sources : scripts,
+ rename : renamed,
+ install_dir : get_option('bindir'),
+ install_tag : 'bin',
+ install_mode : 'rwxr-xr-x',
+)