summaryrefslogtreecommitdiff
path: root/include/meson.build
diff options
context:
space:
mode:
authorJannis Hoffmann <jannis@fehcom.de>2024-07-11 13:49:50 +0200
committerJannis Hoffmann <jannis@fehcom.de>2024-07-11 13:49:50 +0200
commit339954714f69bbd395aa9bbe46850dcaa98e9f29 (patch)
tree00b17e206e3acc35303d24f6a1e76bf2de8c5664 /include/meson.build
parent08ce54211ce4b8d6092321ca1b28773a680ddc45 (diff)
convert form make to meson
Add .editorconfig. Removed unused fallback definitions (for POSIX systems).
Diffstat (limited to 'include/meson.build')
-rw-r--r--include/meson.build52
1 files changed, 52 insertions, 0 deletions
diff --git a/include/meson.build b/include/meson.build
new file mode 100644
index 0000000..42439fd
--- /dev/null
+++ b/include/meson.build
@@ -0,0 +1,52 @@
+qlibs_inc = include_directories('.')
+
+qlibs_hdrs = [
+ 'alloc.h',
+ 'base64.h',
+ 'buffer.h',
+ 'byte.h',
+ 'case.h',
+ 'cdbmake.h',
+ 'cdbread.h',
+ 'close.h',
+ 'constmap.h',
+ 'direntry.h',
+ 'dnsresolv.h',
+ 'env.h',
+ 'error.h',
+ 'exit.h',
+ 'fd.h',
+ 'fifo.h',
+ 'fmt.h',
+ 'genalloc.h',
+ 'getln.h',
+ 'getoptb.h',
+ 'iopause.h',
+ 'ip.h',
+ 'lock.h',
+ 'logmsg.h',
+ 'ndelay.h',
+ 'open.h',
+ 'pathexec.h',
+ 'prot.h',
+ 'readclose.h',
+ 'readwrite.h',
+ 'rename.h',
+ 'scan.h',
+ 'seek.h',
+ 'select.h',
+ 'sig.h',
+ 'socket_if.h',
+ 'stralloc.h',
+ 'str.h',
+ 'taia.h',
+ 'tai.h',
+ 'timeoutconn.h',
+ 'timeout.h',
+ 'uint_t.h',
+ 'wait.h',
+]
+
+qlibs_hdr_subdir = 'fehqlibs'
+
+install_headers(qlibs_hdrs, subdir : qlibs_hdr_subdir)