summaryrefslogtreecommitdiff
path: root/man/meson.build
diff options
context:
space:
mode:
authorJannis Hoffmann <jannis@fehcom.de>2024-07-11 13:49:50 +0200
committerJannis Hoffmann <jannis@fehcom.de>2024-07-11 13:49:50 +0200
commit339954714f69bbd395aa9bbe46850dcaa98e9f29 (patch)
tree00b17e206e3acc35303d24f6a1e76bf2de8c5664 /man/meson.build
parent08ce54211ce4b8d6092321ca1b28773a680ddc45 (diff)
convert form make to meson
Add .editorconfig. Removed unused fallback definitions (for POSIX systems).
Diffstat (limited to 'man/meson.build')
-rw-r--r--man/meson.build53
1 files changed, 53 insertions, 0 deletions
diff --git a/man/meson.build b/man/meson.build
new file mode 100644
index 0000000..53c6a41
--- /dev/null
+++ b/man/meson.build
@@ -0,0 +1,53 @@
+qlibs_mans = [
+ 'alloc.3',
+ 'buffer.3',
+ 'byte.3',
+ 'case.3',
+ 'cdbmake.3',
+ 'cdbread.3',
+ 'constmap.3',
+ 'dns.3',
+ 'dnsstub.3',
+ 'env.3',
+ 'error.3',
+ 'fd.3',
+ 'fmt.3',
+ 'getln.3',
+ 'getoptb.3',
+ 'iopause.3',
+ 'ip4.3',
+ 'ip6.3',
+ 'logmsg.3',
+ 'pathexec.3',
+ 'scan.3',
+ 'socket_bind.3',
+ 'socket_connect.3',
+ 'socket_if.3',
+ 'socket_info.3',
+ 'socket_recv.3',
+ 'socket_send.3',
+ 'socket_setup.3',
+ 'socket_tcp.3',
+ 'socket_udp.3',
+ 'str.3',
+ 'stralloc.3',
+ 'taia.3',
+ 'timeout.3',
+ 'timeoutconn.3',
+ 'wait.3',
+]
+
+man_section = get_option('man_section')
+renamed = []
+
+foreach m : qlibs_mans
+ if m.endswith('.3')
+ renamed += m.substring(0, -1) + man_section
+ endif
+endforeach
+
+install_data(
+ sources : qlibs_mans,
+ rename : renamed,
+ install_tag : 'man',
+ install_dir : get_option('mandir') / ('man' + man_section))