summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL18
1 files changed, 16 insertions, 2 deletions
diff --git a/Makefile.PL b/Makefile.PL
index 6e1ef4c..312fb5a 100644
--- a/Makefile.PL
+++ b/Makefile.PL
@@ -2,20 +2,34 @@ use ExtUtils::MakeMaker;
WriteMakefile(
AUTHOR => '"Jannis M. Hoffmann" <jannis@fehcom.de>',
+ ABSTRACT_FROM => 'lib/JWebmail.pm',
MIN_PERL_VERSION => 'v5.22',
NAME => 'JWebmail',
VERSION_FROM => 'lib/JWebmail.pm',
LICENSE => 'gpl_3',
PREREQ_PM => {
Mojolicious => '9.19',
- Crypt::URandom => 'v0.36',
+ Crypt::URandom => '0.36',
Digest::HMAC_MD5 => '1.04',
Email::MIME => '1.949',
Mail::Box::Manager => 'v3.9',
Role::Tiny => 'v2.2',
- Class::Method::Modifiers => 'v2.13',
+ Class::Method::Modifiers => '2.13',
TOML::Tiny => '0.15',
namespace::clean => '0.27',
},
+ EXE_FILES => ['script/jwebmail', 'script/qmauth.pl'],
test => {TESTS => 't/*.t'},
+ META_MERGE => {
+ 'meta-spec' => { version => 2 },
+ resources => {
+ bugtracker => {web => 'https://github.com/D1CED/JWebmail/issues'},
+ repository => {
+ type => 'git',
+ url => 'git://github.com/D1CED/JWebmail.git',
+ web => 'https://github.com/D1CED/JWebmail',
+ },
+ },
+ },
)
+