summaryrefslogtreecommitdiff
path: root/Makefile.PL
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.PL')
-rw-r--r--Makefile.PL20
1 files changed, 20 insertions, 0 deletions
diff --git a/Makefile.PL b/Makefile.PL
new file mode 100644
index 0000000..ea55cd8
--- /dev/null
+++ b/Makefile.PL
@@ -0,0 +1,20 @@
+use strict;
+use warnings;
+
+use ExtUtils::MakeMaker;
+
+WriteMakefile(
+ AUTHOR => '"Jannis M. Hoffmann" <jannis@fehcom.de>',
+ MIN_PERL_VERSION => 'v5.18',
+ NAME => 'JWebmail',
+ VERSION_FROM => 'lib/JWebmail.pm',
+ LICENSE => 'GPL',
+ PREREQ_PM => {
+ 'Mojolicious' => '8.57',
+ 'File::Type' => 0,
+ 'Email::MIME' => 0,
+ 'Config::Tiny' => 0,
+ 'Mail::Box::Manager' => 0,
+ },
+ test => {TESTS => 't/*.t'}
+); \ No newline at end of file