summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJannis M. Hoffmann <jannis@fehcom.de>2023-09-20 15:34:05 +0200
committerJannis M. Hoffmann <jannis@fehcom.de>2023-09-20 15:34:05 +0200
commit52219f0c3fa2166e48c00eb548f9701bbd0024be (patch)
treee719d08fc928395683f94b704540b83396f72993 /Cargo.toml
parent4104f2b5ce8db469be935dd9dda2ecd815c3706b (diff)
update dependencies; add release-small profile
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml7
1 files changed, 6 insertions, 1 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 314203d..72530f0 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -6,8 +6,13 @@ edition = "2021"
rust-version = "1.70"
resolver = "2"
-[profile.release]
+[profile.release-small]
+inherits = "release"
+opt-level = "s"
+strip = true
lto = true
+panic = "abort"
+codegen-units = 1
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html