summaryrefslogtreecommitdiff
path: root/Cargo.toml
diff options
context:
space:
mode:
authorJannis M. Hoffmann <jannis@fehcom.de>2024-03-14 22:52:36 +0100
committerJannis M. Hoffmann <jannis@fehcom.de>2024-03-14 22:52:36 +0100
commit80f3c54a9c33d27802bc59538932d163b00d9e95 (patch)
treecdbd94ff101fbe1d657aef02f9dd01cda5bc6506 /Cargo.toml
parent285fa4d40144c4c81fafe7865dfdf866b8ddf980 (diff)
convert to protobuf
Diffstat (limited to 'Cargo.toml')
-rw-r--r--Cargo.toml17
1 files changed, 10 insertions, 7 deletions
diff --git a/Cargo.toml b/Cargo.toml
index 72530f0..c733b18 100644
--- a/Cargo.toml
+++ b/Cargo.toml
@@ -1,9 +1,9 @@
[package]
name = "jwebmail-extract"
-version = "0.6.0"
+version = "0.7.0"
authors = ["Jannis M. Hoffmann <jannis@fehcom.de>"]
edition = "2021"
-rust-version = "1.70"
+rust-version = "1.75"
resolver = "2"
[profile.release-small]
@@ -16,13 +16,16 @@ codegen-units = 1
# See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html
+[build-dependencies]
+anyhow = "1.0"
+protobuf-codegen = "3.4"
+
[dependencies]
+chrono = "0.4"
+clap = { version = "4.5", features = ["derive"] }
libc = "0.2"
+log = "0.4"
maildir = "0.6"
-serde_json = "1.0"
-serde = { version = "1.0", features = ["derive"] }
mailparse = "0.14"
-chrono = "0.4"
-clap = { version = "4.0", features = ["derive"] }
-log = "0.4"
+protobuf = "3.4"
simplelog = "0.12"