summaryrefslogtreecommitdiff
path: root/ucspi-tcp6-deb/debian/rules
diff options
context:
space:
mode:
Diffstat (limited to 'ucspi-tcp6-deb/debian/rules')
-rwxr-xr-xucspi-tcp6-deb/debian/rules31
1 files changed, 16 insertions, 15 deletions
diff --git a/ucspi-tcp6-deb/debian/rules b/ucspi-tcp6-deb/debian/rules
index 46f9a49..d5122ea 100755
--- a/ucspi-tcp6-deb/debian/rules
+++ b/ucspi-tcp6-deb/debian/rules
@@ -6,29 +6,30 @@ export DH_VERBOSE = 1
#export DEB_LDFLAGS_MAINT_APPEND = -Wl,--as-needed
UPSTREAM_VERSION := $(shell dpkg-parsechangelog --show-field Version | cut -d- -f1)
-export UPSTREAM_VERSION
get-orig-source:
- uscan --download-current-version
+ uscan --download-current-version --no-symlink
+ tar -xf ../ucspi-tcp6-$(UPSTREAM_VERSION).tgz --strip-components=2
+ mv ucspi-tcp6-$(UPSTREAM_VERSION)/ ucspi-tcp6
+ rm ucspi-tcp6/conf-* ucspi-tcp6/INSTALL.md
+ rm -r ucspi-tcp6/package/
+ tar -czf ../ucspi-tcp6_$(UPSTREAM_VERSION).orig.tar.gz ucspi-tcp6
+ rm -r ucspi-tcp6/
%:
dh $@ --buildsystem=none
override_dh_auto_clean:
- -tar -xf ../ucspi-tcp6_$(UPSTREAM_VERSION).orig.tar.gz --strip-components=1
- rm -f ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/conf-cc
- rm -f ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/conf-ld
- rm -f ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/src/hassgact.h
- rm -f ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/src/hasshsgr.h
- rm -f ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/src/sysdeps
- rm -f ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/src/systype
- $(MAKE) -C ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/src clean
- rm -f ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/src/home
+ -tar -xkf ../ucspi-tcp6_$(UPSTREAM_VERSION).orig.tar.gz --strip-components=1
+ rm -f conf-cc
+ rm -f conf-ld
+ rm -f src/home
+ $(MAKE) -C src clean
override_dh_auto_configure:
- echo "$(CC) -Iinclude `pkg-config -cflags qlibs` $(CFLAGS)" >ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/conf-cc
- echo $(CC) >ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/conf-ld
- touch ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/src/home
+ echo "$(CC) -Iinclude `pkg-config -cflags qlibs` $(CFLAGS)" >conf-cc
+ echo $(CC) >conf-ld
+ touch src/home
override_dh_auto_build:
- $(MAKE) -C ucspi-tcp6/ucspi-tcp6-$(UPSTREAM_VERSION)/src default
+ $(MAKE) -C src default