summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJannis Hoffmann <jannis@fehcom.de>2024-07-03 23:09:39 +0200
committerJannis Hoffmann <jannis@fehcom.de>2024-07-03 23:09:39 +0200
commita42c2a846d854d5b1ad42e27ee7091c72d2b5080 (patch)
tree2278f8fca96c02a0c7f97a40fb85f9e8a4b2deeb /meson.build
parente6e9663d40f7aab9e1982dddcaa11386551ad182 (diff)
convert to the meson build system
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build24
1 files changed, 24 insertions, 0 deletions
diff --git a/meson.build b/meson.build
new file mode 100644
index 0000000..3354e80
--- /dev/null
+++ b/meson.build
@@ -0,0 +1,24 @@
+project('sqmail', 'c', 'cpp',
+ meson_version : '>=1.3',
+ version : '4.2.29a',
+ default_options : ['c_std=gnu99', 'cpp_std=c++11'])
+
+qlibs_dep = dependency('qlibs', fallback : ['fehQlibs', 'qlibs_dep'])
+dnsresolv_dep = dependency('dnsresolv', fallback : ['fehQlibs', 'qlibs_dnsresolv_dep'])
+
+if get_option('build-clients') or get_option('build-pam')
+ ucspissl_dep = dependency('ucspissl', fallback : ['ucspi-ssl', 'ucspissl_dep'],
+ default_options : ['lib-only=true'])
+else
+ ucspissl_dep = disabler()
+endif
+
+crypt_dep = dependency('libcrypt')
+
+idn2_dep = dependency('libidn2', required : get_option('idn2'))
+
+ssl_dep = dependency('libssl', version : '>=1.1')
+crypto_dep = dependency('libcrypto')
+
+subdir('src')
+subdir('man')