summaryrefslogtreecommitdiff
path: root/src/include/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'src/include/meson.build')
-rw-r--r--src/include/meson.build64
1 files changed, 64 insertions, 0 deletions
diff --git a/src/include/meson.build b/src/include/meson.build
new file mode 100644
index 0000000..5f621f5
--- /dev/null
+++ b/src/include/meson.build
@@ -0,0 +1,64 @@
+sqmail_hdrs = [
+ 'base64.h',
+ 'commands.h',
+ 'constmap.h',
+ 'control.h',
+ 'date822fmt.h',
+ 'datetime.h',
+ 'dkimbase.h',
+ 'dkim.h',
+ 'dkimsign.h',
+ 'dkimverify.h',
+ 'dnsdoe.h',
+ 'dnsgettxt.h',
+ 'dns.h',
+ 'exit.h',
+ 'extra.h',
+ 'fifo.h',
+ 'fmtqfn.h',
+ 'gfrom.h',
+ 'global.h',
+ 'headerbody.h',
+ 'hfield.h',
+ 'hier.h',
+ 'hmac_md5.h',
+ 'ipalloc.h',
+ 'ipme.h',
+ 'maildir.h',
+ 'md5.h',
+ 'mfrules.h',
+ 'myctime.h',
+ 'newfield.h',
+ 'now.h',
+ 'prioq.h',
+ 'prot.h',
+ 'qlx.h',
+ 'qmail.h',
+ 'qsutil.h',
+ 'quote.h',
+ 'rcpthosts.h',
+ 'readsubdir.h',
+ 'readwrite.h',
+ 'received.h',
+ 'recipients.h',
+ 'sendtodo.h',
+ 'sha1.h',
+ 'sha256.h',
+ 'smtpdlog.h',
+ 'spf.h',
+ 'srs2.h',
+ 'strset.h',
+ 'tcpto.h',
+ 'tls_errors.h',
+ 'tls_remote.h',
+ 'tls_start.h',
+ 'tls_timeoutio.h',
+ 'token822.h',
+ 'trigger.h',
+ 'triggerpull.h',
+ 'wildmat.h',
+]
+
+sqmail_hdrs_subdir = 'sqmail'
+
+install_headers(sqmail_hdrs, subdir : sqmail_hdrs_subdir)