diff options
author | Jannis M. Hoffmann <jannis@fehcom.de> | 2024-11-21 21:14:40 +0100 |
---|---|---|
committer | Jannis M. Hoffmann <jannis@fehcom.de> | 2024-11-21 21:14:40 +0100 |
commit | 48c2945172b88c35c187d298a35bf26716af4e91 (patch) | |
tree | 2af21ddb4dcacd191e07fef156609b7c1488ebaf /Cargo.toml | |
parent | 6ed535387df0dffa72a10e601b8ea37c99345d84 (diff) |
Switch to varlink as IPC protocol
This is a lot! Whole new design on top of a statefult varlink interface.
You can now handle multiple request response cycles over a single
connection.
The error responses are lot more refined than just status codes with
optional messages and finally part of the protocol.
TODO: A lot of error handling needs to be improved.
Diffstat (limited to 'Cargo.toml')
-rw-r--r-- | Cargo.toml | 12 |
1 files changed, 7 insertions, 5 deletions
@@ -16,15 +16,17 @@ codegen-units = 1 # See more keys and their definitions at https://doc.rust-lang.org/cargo/reference/manifest.html [build-dependencies] -anyhow = "1.0" -protobuf-codegen = "3.4" +varlink_generator = "10.1.0" [dependencies] chrono = "0.4" -clap = { version = "4.5", features = ["derive"] } libc = "0.2" log = "0.4" +simplelog = "0.12" maildir = "0.6" mailparse = "0.14" -protobuf = "3.4" -simplelog = "0.12" +varlink = "11.0.1" +serde = "1.0.215" +serde_json = "1.0.133" +serde_derive = "1.0.215" +base64 = "0.22.1" |